Many websites will not work on older Android versions in 2021

Many websites will not work on older Android versions next year - Tech News - Baaythak
Photo Credit: Shutterstock

If you are using an old Android phone then it is time to upgrade it. According tot he reports, you will no longer be able to access any of the secure websites from your older Android devices. In 2021 when you will try to access a secure website from the older phone the devices will receive the certificate errors.

Most of the web uses HTTPS in order to securely transmit the information after a push from Google. It means that various websites could encounter the problems if the proper certificates are not installed on your device which is what is going to happen to the older Android devices in 2021.

Let’s Encrypt is one of the main and leading certificate authorities and certificates issued by this group are used by more than 30% of all the web domains. When this group was founded it applied for ISRG Root X1 root certificate to be included in all the browsers as well as operating systems. All the certificates till date have been cross-signed with IdenTrust’s DST Root X3 root which has been in macOS, Windows, Android and many other software platforms.

The original partnership of Let’s Encrypt with IdenTrust expires on 1st September, 2021 and the group has no plans on entering another cross-signing agreement. This means that all the browsers as well as operating systems without Let’s Encrypt root certificate will no longer work with the sites and services by using the group’s certificated. According to the announcement the devices which are running on Android 7.1 or lower will be affected.


What are your thoughts about this story? Share your thoughts in the comments section below.

One thought on “Many websites will not work on older Android versions in 2021

Your Comments

%d bloggers like this: